use strict;
my $str = '? this is a ? test ?';
my $regex = qr/\?(.*)\?/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";