package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(2(?:2[4-9]|3[0-9]))\.([0-2]?[0-9]?[0-9])\.([0-2]?[0-9]?[0-9])\.([0-2]?[0-9]?[0-9])$`)
var str = `255.255.255.0
225.3.3.3
255.0.0.0
229.0.0.20
192.168.0.0
8.8.8.8
199.111.111.111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}