# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-?0*\.0+\b|\.0+(?=,|$)|(?:^|(?<=,))(-)?0+(?=\.)|(?<=[1-9])0+(?!\.)\b/$1/gm;t' <<< "2.0,3.00,-4.0,0.00,-0.00,0.03,2.01,0.001,-0.03,101,.50"