$re = '/^.+?(?=part\s*1|part\s*2|$)/m';
$str = ' Any words here part 1
Any words here part 2
Any words here
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);