$re = '/^(?!.*[a-zA-Z0-9]{8,} \d*).+$/m';
$str = 'Hello 23, abc 2, me 5,
My8Chara 12, abc 2,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);