$re = '/(_t\s*\(\s*([\'\"])(\d+)\2\s*,\s*([\'\"])(.*?)(?)\4\s*(?(?=,)[^\)]*\s*\)|\)))/';
$str = '_t(\'123\', \'шт.\', \'\', $userLang) . $data[\'ticker\'] . \' (\' . $data[\'security_name\'] . \')';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);