re = /^(.+\.)??(.*v10.+|.*watson.|.*vortex.|1drv|llnw|.*win.+|.ms.+|.*a.microsoft.+)\.(com|net)$/m
str = 'http-e-darwin.hulustream.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end