import re
regex = re.compile(r"\B#([a-fA-F0-9]{6}|[a-fA-F0-9]{3})\b")
test_str = ("#fff\n"
"#fefefe\n"
"#242424\n"
"#24ff33\n"
"#24ff3o //o is not a valid hex value")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")