package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\(([^)]*)\)\s*([^(\r\n]*?)\s*\(([^)]*)\)|\[([^\]]*)\]\s*([^(\r\n]*?)\s*\[([^\]]*)\])\.(.*)$`)
var str = `(garbage info) filename (other garbage).extension
[garbage info] filename [other garbage].extension`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}