const regex = new RegExp('[^_]*$', 'gm')
const str = `a_b`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);