$re = '/[^\r\n\t\f\v ]\S/';
$str = 'asdfas dfsk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);