import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![^\\s=])(?!(?:true|false)(?![^=\\s]))[^\\s=]{1,50}(?![^=\\s])";
final String string = "true=false true=true false=true false=false some=false true=some\n"
+ "some=true false=true some=some rrrrrr==rrr true";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}