re = /(?<=owner of )[^,.]+/m
str = 'Mr. Mammon Moneybags is a British businessman, owner of Widgets Incorporated, the widget company, and owner of Supermarts chain store.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end