re = /(?<!\S)(\w+)\s+\1(?!\S)/m
str = 'Paris in the the spring.
Not that that is related.
Not that that that is related.
This is $word word'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end