re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[!@#\$%\^&\*])(?=.{6,})/m
str = '&zA12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end