const regex = new RegExp('[^;].*__ctrl1_.*\\(', 'ig')
const str = ` ; Obsidian__CTRL1_B(isHold, taps, state)
Obsidian__CTRL1_N(isHold, taps, state)
; Opus__CTRL1_Z(isHold, taps, state)
; Opus__CTRL1_X(isHold, taps, state)
; Opus__CTRL1_C(isHold, taps, state)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}