#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^\s*[^\s;]"
Local $sString = " ; Obsidian__CTRL1_B(isHold, taps, state)" & @CRLF & _
" Obsidian__CTRL1_N(isHold, taps, state)" & @CRLF & _
" ; Opus__CTRL1_Z(isHold, taps, state)" & @CRLF & _
" ; Opus__CTRL1_X(isHold, taps, state)" & @CRLF & _
" ; Opus__CTRL1_C(isHold, taps, state)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")