$re = '/<a\s.*?>(.*?)<\/a>|\/\s+([^\n]+)\s+<\/div>/s';
$str = '<div id="bread-crumbs">
<a href="/">HOME</a> /
<a href="/deep1">Deep 1</a> /
<a href="/deep2">Deep 2</a> /
TFXF2X - FDS<34>0C500 (78-12)
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);