package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(s|f|dn)|(\d{2}d)$`)
var str = `ss
dnf
305d
sf
35d
s
f
dn
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}