# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bM[rs]\.\h(\p{Lu}\p{Ll}+(?:[\h-]\p{Lu}\p{Ll}+)*)\b"
test_str = ("21. The SBSTA considered this agenda item at its 1^st^ meeting and resumed 3^rd^ meeting, on 15 November. It had before it document FCCC/SB/2016/3. At its 1^st^ meeting, the SBSTA agreed to consider this agenda item together with agenda item 11 of the SBI in informal consultations co-facilitated by Ms. Beth Lavender (Canada) and Mr. Alf Wills (South Africa). As referred to by the COP,[^18] the SBSTA also considered the issue of the review of the Warsaw International Mechanism for Loss and Damage associated with Climate Change Impacts, and agreed that it would be discussed at the same informal consultations. At its resumed 3^rd^ meeting, the SBSTA recommended two draft decisions on these matters for consideration and adoption at COP 22.[^19]. Mr. Seen and Mr. Conwell participate actively to the reconciliation. \n"
"Mr. Raúl Estrada-Oyuela (Argentina)\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.