$re = '/(?:(?P<sign>(?:(?<=\s)|^)[-+])|\b)(?:0*)(?P<value>\d+(?:[\.,]\d+)*)\b/m';
$str = 'The-number-30
The number 30
\'I am a 30something
That just40 should be ignored
What about 30+ apples? and +30 then or -30?
The 2nd apple is ignored now. 30" and \'2\' is still okay.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);