using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!') *+(\[[^\]]*\]) *+(?!')";
string input = @"[field1] = 'id1'
[field1] = '[field2]'
[ field1 ] = '[field2]'
[field1] = ' [field2] '
[field1] = ' [field2] ' And [field3] = '[field4] '' [field5]'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}