re = /(?<=[$€£])[0-9]+[.,]?[0-9]+/m
str = 'Something $95+$5 something
Something $94.50+$5.50 something
Something €94,50+€5,50 something
Something £94.50+£5.50 something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end