$re = '/^(\/\/|\*)*\s*(?i)(?=(@*to(-|\s|)+do))(?-i)(?!@todo\s(?!-|:)\S)/mi';
$str = '@todo Something
@todo Something
@todo This is something I should not forgot to do.
@to-do Something
@TODO Something
@ToDo Something
@TO-DO Something
@TO do Something
@to do Something
@todo: Something
@todo : Something
@todo- Something
@todo - Something
@todoSomething
todo something
todo Something
@to-do Something
todo Something
@todoSomething
@todo: This is something I should not forgot to do.
@todo - this is something I should not forgot to do.
@todo this is something I should not forgot to do.
@todo This is something I should not forgot to do.
TODO: This is something I should not forgot to do.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);