re = /(?:\G(?!^),|p\()(\w+_\d+(?:-p(\((?:[^()]++|(?2))*\)))?)/m
str = 'T_0-p(T_1-p(T_2,K_0),CW_0)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end