package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(?P<message>{.*})`)
var str = `{"channel":"crm_process_booking_log","log_type":"DEBUG","index_name":"crm_process_booking_log","index_type":"crm_process_booking_log","error_type":0,"message":{"data":{"STEP":"Adding Post Data","post_data":{"customer":[{"relation":"others","age":28,"dob":null,"gender":"F","email":null,"customer_id":"66aff7d8-cd9b-4796-bf17-e66088c3565a","customer_name":"Prena","contact_number":null}],"slot":{"slot_id":"684178718"},"gender":"M","mobile":"6700670875","email":"siddhant.khanna_testi_blr+rahul@acko.tech","state":"26","cityId":"23","latitude":28.5101825,"longitude":77.0682661,"address":"sector 21, gurgaon, Gurgaon, Haryana, 122016","zipcode":"122016","landmark":"home","altmobile":false,"altemail":false,"package":[{"deal_id":["package_216"]}],"customer_calling_number":"6700670875","billing_cust_name":"Rahu","sub_locality":"sector 21, gurgaon, Gurgaon, Haryana, 122016","hard_copy":0,"vendor_booking_id":false,"vendor_billing_user_id":"4rWzYn5NOhEgNPdiVGWiRA","payment_option":"invoice","discounted_price":0,"sample_collected":"n","role_id":0,"search_by":"customer_mobile","channel_partner":"3","channel_partner_user":"5490","booked_source":"api","zip_search":2,"calling_from":"external_api","b2bNewExistingUser":false,"user_id_ajax":"","whatsappconcent":1,"billing_zone_id":"53","zone_id":"53","amzn_trace_id":"Root=1-65c33f1c-29fe535658001b076140677c","billing_cust_city":"gurgaon","billing_cust_city_id":"23","locality":"541","channel_type":"3","channel_user":"5490"},"amzn_trace_id":"Root=1-65c33f1c-29fe535658001b076140677c"},"calling_trace":{"file":"\/var\/www\/newcrm-t25\/application\/controllers\/crmuser\/crmorder.php","line":1227,"function":"addProcessBookingLog","class":"Enterprise_logger"}},"amzn_trace_id":"Root=1-65c33f1c-29fe535658001b076140677c","nginx_request_id":"c93176430784c9dd4e32e35541e6e31a","timestamp":"2024-02-07 13:58:12"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}