$re = '/(^\d{4}$)|(^.*£.*$)/m';
$str = '1234
0000
oeu
4321
12345
123456
o1234a
551234
123
£1
£1414
£123
something£££££morething
£ 12345 £';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);