const regex = new RegExp('(?:[@#$:]\\w+[^@#$:\\n]*){5}', 'gm')
const str = `@someword someotherword anotherword word1 word2 word3
@someword :someotherword #anotherword \$word1 word2 word3
@someword :someotherword #anotherword \$word1 #word2 \$word3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}