#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?s)\S+@\S+?((?:says?|:)?\s.*?)(?:\s+Message ID|\* +\* +\*)"
Local $sString = "Message ID: SM9MatRNTnMAYaylR0QgOH///qUUveBCbw== " & @CRLF & _
" 2021-07-10T20:48:23.997Z john s (X Y Bank) -" & @CRLF & _
" john.s@xy.com: " & @CRLF & _
" [EVENT] 347376954900491 (john.s@xy.com) created room" & @CRLF & _
" (roomName='CSTest' roomDescription='CS Test Chat Room' COPY_DISABLED=false" & @CRLF & _
" READ_ONLY=false DISCOVERABLE=false MEMBER_ADD_USER_ENABLED=false" & @CRLF & _
" roomType=PRIVATE conversationScope=internal owningCompany=X Y" & @CRLF & _
" Bank)" & @CRLF & _
" " & @CRLF & _
" Message ID: nsabNaqeXfuEj9mBEhvS0n///qUUveAhbw== " & @CRLF & _
" 2021-07-10T20:48:23.997Z john s (X Y Bank) -" & @CRLF & _
" john.s@xy.comsays " & @CRLF & _
" [EVENT] 347376954900491 (john.s@xy.com) invited 347376954900486" & @CRLF & _
" (kerren.n@xy.com) to room (CSTest|john s|16091907435583)" & @CRLF & _
" " & @CRLF & _
" Message ID: Nu/EYTkTQ5qdbqzZ0Rig8n///qUUvQ42dA== " & @CRLF & _
" 2021-07-10T20:48:23.997Z john s (X Y Bank) -" & @CRLF & _
" john.s@xy.comsays " & @CRLF & _
" " & @CRLF & _
" Catchyou later" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Message ID: dy2yaByqhm+n88Gd3VQOhH///qUUrz8odA== " & @CRLF & _
" 2021-07-10T20:48:23.997Z kerren n (X Y Bank) -" & @CRLF & _
" nancy.n@xy.comsays " & @CRLF & _
" " & @CRLF & _
" KeywordContent_ Cricket is a bat-and-ball game played between two teams of" & @CRLF & _
" eleven players on a field at the centre of which is a 20-metre (22-yard) pitch" & @CRLF & _
" with a wicket at each end, each comprising two bails balanced on three stumps." & @CRLF & _
" The batting side scores runs by striking the ball bowled at the wicket with" & @CRLF & _
" the bat, while the bowling and fielding side tries to prevent this and dismiss" & @CRLF & _
" each player (so they are "out")." & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" * * *" & @CRLF & _
" " & @CRLF & _
" Generated by Content Export Service | Stream Type: SymphonyPost |" & @CRLF & _
" Stream ID: ZZo5pRRPFC18uzlonFjya3///qUUveBHdA== | Room Type: Private |" & @CRLF & _
" Conversation Scope: internal | Owning Company: X Y Bank | File" & @CRLF & _
" Generated Date: 2021-07-10T20:48:23.997Z | Content Start Date:" & @CRLF & _
" 2021-07-10T20:48:23.997Z | Content Stop Date: 2021-07-10T20:48:23.997Z " & @CRLF & _
" " & @CRLF & _
" * * *" & @CRLF & _
" " & @CRLF & _
" *** (780787) Disclaimer: " & @CRLF & _
" (incorporated in paris with Ref. No. ZC18, is authorised by Prudential Regulation" & @CRLF & _
" Authority (PRA) and regulated by Financial Conduct Authority and PRA. oyp and" & @CRLF & _
" its affiliates (We) monitor this confidential message meant for your" & @CRLF & _
" information only. We make no recommendation or offer. You should get" & @CRLF & _
" independent advice. We accept no liability for loss caused hereby. See market" & @CRLF & _
" commentary disclaimers (" & @CRLF & _
" http://wholesalebanking.com/en/utility/Pages/d-mkt.aspx )," & @CRLF & _
" Dodd-Frank and EMIR disclosures (" & @CRLF & _
" http://wholesalebanking.com/en/capabilities/financialmarkets/Pages/default.aspx" & @CRLF & _
" ) "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")