using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"FROM `\K[^`]+";
string input = @"SELECT * FROM `table_name` WHERE `id` = '1'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}