#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"logUser"\s*\:([^\,]+),"
Local $sString = "Aceita vários ":"" & @CRLF & _
"" & @CRLF & _
"{ "logUser":::::::123, "etc" ... } <-- JSON inválido" & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"Aceita "nada" entre os dois-pontos e a vírgula:" & @CRLF & _
"" & @CRLF & _
"{ "logUser": , } <-- JSON inválido" & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"E se tiver logUser no segundo nível?" & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
" "abc": 123," & @CRLF & _
" "segundoNivel": {" & @CRLF & _
" "logUser": 123, <-- não deveria dar match, pois não está no primeiro nível" & @CRLF & _
" }," & @CRLF & _
" "logUser": 123, <-- deveria pegar só esse (e se desativar o flag "g", só iria pegar a ocorrência do segundo nível, pois ela aparece primeiro)" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"Lembre-se que um JSON não garante a ordem das chaves (é um unordered set), então ele pode ser retornado assim, dependendo das libs usadas." & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"A regex força ter uma vírgula no final, mas em um JSON as chaves não tem ordem, então deveria aceitar sem a vírgula também (vai que logUser é o último elemento):" & @CRLF & _
"" & @CRLF & _
"{ "abc": 123, "logUser": "só aceita com vírgula no final", }" & @CRLF & _
"{ "abc": 123, "logUser": "mas deveria aceitar sem vírgula" }" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")