$re = '/^(?=.{1,255}$)([a-zA-Z0-9](?:[A-Z0-9a-z-]{0,61}[a-zA-Z0-9])?)(?:[.]\g<1>)*$/m';
$str = 'I\'m trying to build a regex where it accepts domain names with the following conditions:
Allows DNS names (only hyphens, periods and alphanumeric characters allowed) upto 255 characters.
Hyphens can only appear in between letters
Should start/ end with a letter.
The length of the label before a period should be 63
Possible Cases:
a.b.c
a-a.b
Cases that should not pass
a-.b
qwertqwertqwertqwertqwertqwertqwertqwertqwertqwertqwertqwertqwer.v
What I have built looks like this:
But this does not accept
a.b.c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);