import Foundation
let pattern = #"[а-я]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Remeza AirCast СБ4/С-100 LB 30 3,0 кВт Компрессор масленный"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 $1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}