const regex = /\[(.*?)\]\s*\[(.*?)\]\s*\[(.*?)\]\s*(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(.*?)\\]\\s*\\[(.*?)\\]\\s*\\[(.*?)\\]\\s*(.*)', 'gm')
const str = `[category - subcategory] [some text - more text ] [2018-12-31] text title here
[category - subcategory] [some text] [ 2018 - 12 -31 ] text title here more text
[category] [some text - more text - even more] [2018-12-31] text title here more text
[category] [some text - more text - even more - some text - more text - even more ] [2018-12-31] text title here more text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}