// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(([^-]+-.+)\.png|jpg\)").unwrap();
let string = "(background_apartment_450-533c-d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.png)
(background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.jpg)
background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.jpg
(background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}