package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z]?a`)
var str = `cabcd123dfsavvdsa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}