re = /https:\/\/www.filmxy.vip\/movie\/(.*[^\/])/m
str = 'https://www.filmxy.vip/movie/chupkotha'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end