# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:{\"log\":\"[0-9]{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d+ ERROR \[stderr\].*(?:\n{\"log\":\"[0-9]{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d+ ERROR \[stderr\].*)*|{\"log\":\"[0-9]{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d+ ERROR (?!\[stderr\]).*)"
test_str = ("{\"log\":\"2019-04-18 15:18:19,498 ERROR [org.apache.activemq.ActiveMQSession] (default-threads - 3) error dispatching message: : javax.ejb.EJBTransactionRolledbackException\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.523359025Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,498 ERROR [org.apache.activemq.ActiveMQSession] (default-threads - 3) error dispatching message: : javax.ejb.EJBTransactionRolledbackException\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.523359025Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,498 ERROR [org.apache.activemq.ActiveMQSession] (default-threads - 3) error dispatching message: : javax.ejb.EJBTransactionRolledbackException\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.523359025Z\"}\n"
"{\"log\":\"2019-04-18 15:18:18,796 ERROR [stderr] (default-threads - 3) java.util.NoSuchElementException: No value present\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:18.800485539Z\"}\n"
"{\"log\":\"2019-04-18 15:18:18,804 ERROR [stderr] (default-threads - 3) at java.util.Optional.get(Optional.java:135)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:18.806510971Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,259 ERROR [stderr] (default-threads - 3) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.264689098Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,259 ERROR [stderr] (default-threads - 3) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.281810119Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,274 ERROR [stderr] (default-threads - 3) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.28185714Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,275 ERROR [stderr] (default-threads - 3) at java.lang.reflect.Method.invoke(Method.java:498)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.281867696Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,275 ERROR [stderr] (default-threads - 3) at org.jboss.weld.interceptor.proxy.TerminalAroundInvokeInvocationContext.proceedInternal(TerminalAroundInvokeInvocationContext.java:49)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.281875844Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,498 ERROR [org.apache.activemq.ActiveMQSession] (default-threads - 3) error dispatching message: : javax.ejb.EJBTransactionRolledbackException\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.523359025Z\"}\n\n"
"{\"log\":\"2019-04-18 15:18:18,796 ERROR [stderr] (default-threads - 3) java.util.NoSuchElementException: No value present\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:18.800485539Z\"}\n"
"{\"log\":\"2019-04-18 15:18:18,804 ERROR [stderr] (default-threads - 3) at java.util.Optional.get(Optional.java:135)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:18.806510971Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,259 ERROR [stderr] (default-threads - 3) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.264689098Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,259 ERROR [stderr] (default-threads - 3) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.281810119Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,274 ERROR [stderr] (default-threads - 3) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.28185714Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,275 ERROR [stderr] (default-threads - 3) at java.lang.reflect.Method.invoke(Method.java:498)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.281867696Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,275 ERROR [stderr] (default-threads - 3) at org.jboss.weld.interceptor.proxy.TerminalAroundInvokeInvocationContext.proceedInternal(TerminalAroundInvokeInvocationContext.java:49)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.281875844Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,498 ERROR [org.apache.activemq.ActiveMQSession] (default-threads - 3) error dispatching message: : javax.ejb.EJBTransactionRolledbackException\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.523359025Z\"}\n\n"
"{\"log\":\"2019-04-18 15:18:19,498 ERROR [org.apache.activemq.ActiveMQSession] (default-threads - 3) error dispatching message: : javax.ejb.EJBTransactionRolledbackException\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.523359025Z\"}\n\n"
"{\"log\":\"2019-04-18 15:18:19,498 ERROR [org.apache.activemq.ActiveMQSession] (default-threads - 3) error dispatching message: : javax.ejb.EJBTransactionRolledbackException\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.523359025Z\"}\n"
"{\"log\":\"2019-04-18 15:18:18,796 ERROR [stderr] (default-threads - 3) java.util.NoSuchElementException: No value present\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:18.800485539Z\"}\n"
"{\"log\":\"2019-04-18 15:18:18,804 ERROR [stderr] (default-threads - 3) at java.util.Optional.get(Optional.java:135)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:18.806510971Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,259 ERROR [stderr] (default-threads - 3) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.264689098Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,259 ERROR [stderr] (default-threads - 3) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.281810119Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,274 ERROR [stderr] (default-threads - 3) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.28185714Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,275 ERROR [stderr] (default-threads - 3) at java.lang.reflect.Method.invoke(Method.java:498)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.281867696Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,275 ERROR [stderr] (default-threads - 3) at org.jboss.weld.interceptor.proxy.TerminalAroundInvokeInvocationContext.proceedInternal(TerminalAroundInvokeInvocationContext.java:49)\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.281875844Z\"}\n"
"{\"log\":\"2019-04-18 15:18:19,498 ERROR [org.apache.activemq.ActiveMQSession] (default-threads - 3) error dispatching message: : javax.ejb.EJBTransactionRolledbackException\\n\",\"stream\":\"stdout\",\"time\":\"2019-04-18T19:18:19.523359025Z\"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.