$re = '/(.+(?=@example1\.com$)|.*)/m';
$str = 'test@example1.com
test@example2.com
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;