$re = '/casenumber(\s*[^\s\d]+\s*\d{7,8})+/';
$str = 'Hi!
Hereby I would like to confirm that I will be present at the meeting about casenumber: 1234567, 98765432, and 7654321.
Can you confirm that you have received this email?
Kind regards,
Random person';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);