$re = '/([\w_+.]+)@([\w_.]+)/m';
$str = '"From: Name email@email.co.uk mailto:Name@email.co.uk text text text"
"From: Name firstname.lastName@email.com mailto:firstname.lastName+something@email.com text text text"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);