$re = '/^((?:\w+\W+){2}).*(\w+)\W+\w+$/';
$str = 'CSC 101 Intro to Computing A R';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);