package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<statuscode>\d+)\s\d+\s\d+\s\d+$`)
var str = `405 0 0 456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}