$re = '/([A-Z a-z 0-9 ,;&!@#$%^&*()-`~=+ ]*)(?=">)/m';
$str = '<meta name="description" content="TEst text, here is the text extracted">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);