import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+(\\W)\\w+(\\1\\w+)+";
final String string = "abcd.efgh.1234.4567\n"
+ "abcd-efgh-1234-4567\n"
+ "abcd|efgh|1234|4567\n"
+ "abcd.efgh-1234|4567";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}