$re = '/(?<=^|Hello)(?:(?!Hello|Goodbye).)+(?=Goodbye|$)/m';
$str = 'Hello, I like you. Goodbye.
Hello there, do you enjoy golf?
I like you. Goodbye. See you later.
HelloGoodbye
Goodbye, how are you?
How are you? Hello
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);