re = /("[^"\\]*(?:\\[\S\s][^"\\]*)*"|'[^'\\]*(?:\\[\S\s][^'\\]*)*'|\/[^\/\\]*(?:\\[\S\s][^\/\\]*)*\/[gimy]*(?=\s|$)|(?:\\\s|\S)+)/
str = 'echo "©\\\\\\\\\\" abc " baz"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end