$re = '/("[^"\\\\]*(?:\\\\[\S\s][^"\\\\]*)*"|\'[^\'\\\\]*(?:\\\\[\S\s][^\'\\\\]*)*\'|\/[^\/\\\\]*(?:\\\\[\S\s][^\/\\\\]*)*\/[gimy]*(?=\s|$)|(?:\\\\\s|\S)+)/';
$str = 'echo "©\\\\\\\\\\" abc " baz"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);