re = /((?:"[^"\\]*(?:\\[\S\s][^"\\]*)*"|'[^'\\]*(?:\\[\S\s][^'\\]*)*'|\/[^\/\\]*(?:\\[\S\s][^\/\\]*)*\/[gimy]*(?=\s|$)|(?:\\\s|\S))+)(?=\s|$)/
str = 'echo and"©\\\\\\\\\\" abc " baz"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end