re = /(?:\\\/)?\(\?\:(?:\\\/)?\(\[\^(?:\\)?\/\]\+\?\)\)\\\//m
str = '/^(?:\\/([^/]+?))\\/?(?=\\/|$)/i
/^\\/(?:([^\\/]+?))\\/?(?=\\/|$)/i'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end